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Species Count Procedure

I. Introduction

This procedure outlines the process of a species count on a grid that covers Baldwin and
Mobile, Alabama, county areas including the greater Mobile and Pensacola urban areas. The grid
is based on selecting all of the U.S.G.S 7.5 minute quadrangles that cover the region, and then
dividing the quadrangles into halves along an east-west axis, and into thirds along a north-south
axis. The object of the procedure is to accumulate the number of a particular species that fall
within a grid square. The species location data should be in decimal latitude and longitude
coordinates, and is typically collected with a GPS receiver and downloaded to a spreadsheet.
This outline uses ArcGIS 9.1 to process the data. The end result will be a map that is color-coded
by grid square based on the number of species that plot within a grid square. With this product it
is possible to immediately evaluate species concentration over the two-county area, and it is also
possible to analyze the concentrations statistically with, for example, the Geostatistics Analyst
module in ArcGIS.

Before beginning the below steps you should note that specific files that compose the
base maps of the project are assumed to be located in the following locations:

Folder: C:\ArcGIS_Data\USA\
1. Dtl_st.sdc files (sdc, sdi,xml extensions)  (state boundaries)
2. Urban_dtl files (shx, shp, dbf, prj, xml, sbx, sbn, avl extensions) (urban areas)
3. Dtl_wat files (sdc, sdi, xml extensions) (water bodies)
4.Dtl_riv files (sdc, sdi, xml extensions) (rivers and streams)
5. Mjrrds files (shx, shp, dbf, prj, xml, sbx, sbn, avl extensions) (major roads)
6. Topoq24 (shx, shp, dbf, prj, xml, sbx, sbn, avl extensions) (24K topo coverage)

Working Folder: C:\ArcGIS_Data\XXX\SpeciesCount\
1. AL_countyBoundaries files  (shx, shp, dbf, prj, xml, sbx, sbn, avl extensions)
(Alabama county boundaries)
2. Grid files (shx, shp, dbf, prj, xml, sbx, sbn, avl extensions) (counting grid)
3. AL_FL_MS_CensusBlocks files (shx, shp, dbf, prj, xml, sbx, sbn, avl extensions) (AL,
Fl, MS census block data )

Create the working folder on your workstation substituting your own initials for the “XXX” in
the path name. Download the starting working folder files from the web link:

http://www.usouthal.edu/geography/allison/gy461/SpeciesCountFiles.exe
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Unzip the files into your working folder using winZIP (or equivalent) utility. With File Explorer
check to make sure that the working folder starting files listed above are in the working folder.

Next you need to make sure that the USA data files are on your workstation on the correct path.
Use Explorer to make sure that the folder exists and that the required files listed above are
present (Dtl_st.sdc, Dtl_water.sdc, etc.). If these are not present you need to copy them from the
lab server over the network. Alternatively, you can download the files from:

http://www.usouthal.edu/geography/allison/gy461/USA_Base_Map.zip

Note that the download time may be long because of the size of this file (> 300 Mb).  

Open the starting project file named “SpeciesCountBaseMap.mxd”. Immediately select “File >
Save As” and save this project to your working folder as “SpeciesCountProject.mxd”. You
should now see displayed a fairly detailed map centered on Mobile and Baldwin counties with
various features such as drainage and roads. Using the “Add Data” button add the “Grid.shp”
layer to the project. Double-click on the “Grid” layer symbol and select the “Hollow” type
symbol so that the map background displays through the grid polygons. Save the results.

II. Step 1: Unioning the Grid and Sample Data

This process will “Union” the sample location points with the counting grid. The
counting grid is a polygon topology, whereas the sample locations are a point topology. The
counting grid is already defined, so the first part of this step is converting an Excel spreadsheet
of GPS sample locations into an ArcGIS point topology. Open the file “ChineseTallow.xls” to
view the raw data. In the spreadsheet the 1st sheet named “Observations” contains all the details
regarding where and when Chinese Tallow trees were observed in Mobile and Baldwin counties.
This species, which is considered an invasive pest, was noted and location logged with a hand-
held GPS receiver. The 2nd sheet named “GPS” contains the decimal degree longitude and
latitude of each observation along with a sample index number. Verify that you have this sheet
displayed by comparing your view to Figure 1. While this sheet is active, choose the menu
sequence “File” > “Save As”. Choose the option to save as a “dBase IV” file (extension = .DBF).
Your dialog window should appear as in Figure 2.  As indicated in the figure name the new file
“ChineseTallow.dbf”. Excel will display 2 warnings during the saving process- in both cases
indicate that you want to proceed with the saving process regardless of any lost formatting. 

For the next stap start the ArcMap application from the desktop and load the
“SpeciesCountProject.mxd” file. At this point you need to add the GPS data points to this base
map. To do this you need to used the “Add XY Data” tool. Before you attempt this step, make
sure that the “ChineseTallow.dbf” file is not still active in Excel. To make sure this is not a
problem close Excel at this time. Select the ArcMap menu option  “Tools” > “Add XY data”.
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Figure 3 displays the resulting dialog window generated by this choice. Fill in the dialog
window as indicated in Figure 3. After selecting the “OK” button you should see your data plot
in both counties. If this is not the case seek help from your instructor at this time. Figure 4
displays the GPS data points plotted on the base map.  At this time save your project.

The GPS data points now plotted in the “Chinese Tallow Events” layer is not a true point
coverage so they must be converted to a shape file point coverage layer. Highlight the “Chinese
Tallow Events” layer and then right-click on the highlight and select “Data” > “Export Data”.
This will generate the dialog in Figure 5. As indicated in the dialog name the new layer file
“CTallow.shp”. After selecting the “OK” button indicate “Yes” when ArcMap asks if you want
to add the new layer to the project. You can turn off the “Chinese Tallow Events” layer at this
time. The “CTallow” layer should have points in the same location as the previous “Chinese
Tallow Events” layer.

The next step is the actual “intersecting” overlay operation between the grid polygon coverage
and the GPS data point coverage. This operation will yield another point coverage layer. In this
new point coverage layer each point will contain an ID number that identifies in which grid
square it is located. To start the process activate the ArcGIS toolbar from the toolbar menu (the
red toolbox icon). Within the new ArcToolbox window select the “Analysis Tools” > “Overlay”
> “Intersect” tool option. Figure 6 demonstrates how you should fill in the dialog activayed by
the “Intersect” tool option. Select the “OK” button to process the intersect operation. The point
coverage generated by this tool will automatically be added to the project. At this time check the
new intersect point coverage by selecting the information icon (toolbar- blue filled circle with
“i” in the center). Make the current layer in the information dialog window “GridCount”. Turn
off the “Ctallow” layer, and then select one of the “GridCount” points with the cursor. You
should now see results similar to Figure 7. Note that the field “ADMAPKEY” contains the grid
rectangle ID that the point falls within, therefore, the number of points having a specific value of
“ADMAPKEY” is equivalent to the  number of points falling within that grid square area. This
fact allows for the species count of each grid rectangle to be determined. The determination is
easily processed within an Excel spreadsheet so the next step will be to export to Excel.

III. Step 3: Producing the Count Table

In this step you will generate a table of summary statistics that counts the number of occurances
of each unique “ADMAPKEY” code in the “GridCount” layer point coverage. This count is the
number of Chinese Tallow trees that occur in a specific grid square. To process the count right-
click on the “GridCount” layer name and then select “Open attribute table”. You should now see
a new window containing the “GridCount” attributes display. Right-click on the field name
“AcadMapKey” and select the option “Summarize”. You should now see a dialog similar to
Figure 8 displayed. Fill out the dialog as indicated using “ChineseTallowCounts.dbf” as the file
name for the new table. When ArcGIS asks if you want to add the new table to the project
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indicate “Yes”. Right-click on the new table and select “Open” to open the table. The table
should appear as in Figure 9. 

IV. Step 4: Color-Coding the Species Density in ArcMap

This is the really cool part. Highlight the “Grid” layer and then right-click on the highlight.
Select “Properties from the pop-up menu, and then click on the “Joins & Relates” tab. Under the
“Joins” section click on the “Add” button. Fill out the “Join Data” dialog window as indicated in
Figure 10. Now select the “Symbology” tab of the layer properties and set the properties as
indicated in Figure 11. Note that after selecting “Categories > Unique Values”, you should then
set the “Values Field” to “Count.ADMAPKEY”, and then click on the “Add all values” button to
add the levels of counts. Double click on the “Null” count color box and change it to a “hollow”
color. Your map should now appear similar to Figure 12. Note that the color coding makes it
easy to visually pick out the areas where Chinese Tallow trees are concentrated. Rename the
layers as indicated in this figure using the “Properties” > “General” option of each layer.

V. Step 5: Produce Hard Copy of Chinese Tallow Count Results

Effective hard copy results in ArcMap requires setting up the data in a layout view. Before you
can do this, however, you need to indicate the output device. Select the “File” > “Page & Print
Setup” option. Configure the dialog as indicated in Figure 13. Note that your printing device
may have a different name than indicated in Figure 13. Now use the “View” > “Layout View” to
set the current view to “Layout” mode. In this mode you can see the media and print margins for
the hard copy. You should now see a view similar to Figure 14.  Use the arrow pointer to
double-click on the title, author and date text to change it to appropriate values. You can now use
“File” > “Print” to produce a hard copy.

VI. Step 6: Statistics

Biologists suspect that the spread of the invasive Chinese Tallow tree species is primarily a
function of people (mostly unintentional) so a statistic measuring the correlation of population to
counts per grid square would be step in the direction of proving or disproving this hypothesis.
Add the census block data layer “AL_FL_MS_censusblocks.shp” to the current project. In this
layer the field “POP04_SQMI” contains the population per square mile for a tri-state area. Using
the “Symbology” tab under the layer “Properties” set the symbology as depicted in Figure 15. 
Turn of the grid layer so that the correlation between sample points and population is clear. Note
that the log of the population is plotted to “smooth” the drastic variation in population density. In
order to calculate a correlation coefficient between species density and population density you
need to have the species count as an integral field in the grid polygon layer. Currently it is a field
in a joined table. The next step copies the values of the count into a new field integral to the grid
polygons. Right-click on the grid layer and select “Open Attribute Table”.  Using the “Options”
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button and “Add new field” add a new field named “CT_Count”. You should now see the new
field “Grid.CT_Count” in the attribute table. All of the values will be “0". Right-click on the
“Grid.CT_Count” field name in the attribute table window and select “Calculate Values”. You
will then see a warning that any calculations will be permanent- indicate “Yes” that you wish to
continue. You will now see displayed the calculation dialog window. Fill it in as indicated in
Figure 16.  Select the “OK” button and then verify in the attribute table that the
“Cnt_ADMAPK” counts were copied over to the “CT_Count” field.

Now we need to intersect the polygon layers “Chinese Tallow Grid” and the
“AL_FL_MS_CensusBlocks” using the ArcToolbox “Overlay” > “Intersect” tool. Fill in the
dialog as indicated in Figure 17. The resulting “CT_POP04" layer contains within the attribute
table the species count and the 2004 population per square mile data. This can be imported into
Excel and analyzed for correlation.

Start Excel and use the “File” > “Open” menu sequence. Change the file type in the dialog to
“.DBF” and navigate to your working folder. Open the “CT_POP04.DBF” file. Immediately save
the file as an Excel type with the “File” > “Save As” menu sequence. Format the spreadsheet to
match the Figure 18 graphic. Many of the columns in the spreadsheet are not applicable to this
study so delete them until the spreadsheet matches the format of Figure 18. Rename the Chinese
Tallow counts heading as “Grid_Count”. Sort the entire spreadsheet in descending order on the
value of “Grid_Count”.  

To the right of the data columns use the “CORREL” function to calculate the correlation statistic
between “Grid_Count” and “POP04_SQMI” (See Figure 18) . Insert an XY graph that plots
these two variables and format it as in Figure 18. Consider the correlation value between
population and Chinese Tallow counts. Does it support the original hypothesis?  

Highlight the Excel chart and use “Edit” > “Copy” to copy the graph to the clipboard. Return to
ArcMap and load your project file. Activate the layout view and turn off the grid layer and
“CT_POP04". Paste the graph on top of the map layout as indicated in Figure 19. Modify the
formatting of the map as indicated in Figure 19, and then print the map to turn in as a product.


