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Figure 1: Hypothetical retrodeformation geometry requiring two stages of rotation.

Introduction

The CROSSBED application is designed to retro-deform cross-bedding data to determine the
paleocurrent direction. The application is designed for process cross-bedding from polydeformed
terranes in a 2-step process:

1. Step 1 rotation: the rotation necessary to make the data station  top/bottomset bed co-
planar to the regional “tangent sheet layer” is calculated. The data station foreset attitude
is rotated in the same manner. If the top/bottomset bed is overturned, the absolute value
of the rotation is greater than 90 degrees. In Figure 1 the angles "1 and "2 represent two
examples of this rotation about the regional fold hinge. Rotating the top/bottomset
bedding attitudes to be coplanar with the tangent sheet layer in effect retro-deforms the
folded layer into a single plane. 

2. Step 2 rotation: the second rotation is determined by calculating the rotation needed to
move the regional tangent sheet layer attitude to the horizontal. The foreset attitude is
rotated in this manner. The down-dip plunge and bearing is the paleocurrent direction. If
a “simple” rotation is selected this step is skipped. The rotation of the tangent sheet layer
to the horizontal attitude is indicated by angle * in Figure 1. 

Any type of paleocurrent data, including cross-bedding,  may be retro-deformed to its original
attitude as long as the primary top/bottomset bedding attitude is known at the location where the
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Figure 2: Example of rotation path for retro-
deformation.

foreset attitude is measured and recorded. If
paleocurrent data is measured from a terrane where
regional folds plunge significantly, the user will
need to determine the attitude of the "tangent sheet
layer" attitude. The tangent sheet layer is defined
as the attitude of the plane that would contain the
regional fold hinge as the true dip vector. If the
regional fold hinge is determined visually or
statistically (i.e. plotting poles to top/bottomset
attitudes to define a cylindrical fold girdle) on a
stereographic projection, rotating the hinge point to
the east-west line of the stereonet and tracing the
great circle that the hinge falls upon will define the
regional tangent sheet layer  attitude. Figure 1
displays the geometry of a plunging regional fold
containing cross-bedding in a schematic example
of a regionally folded terrane with a plunging
hinge. Note that the rotation required to make the
top/bottomset attitude coplanar with the regional
tangent sheet layer is generally unique for each
data observation, and therefore quite tedious to
process manually. The rotation axis for the Step 1
rotation is defined by the pole to the plane that
contains the top/bottomset pole, and the regional
tangent sheet layer pole. This rotation axis will always fall on the regional tangent layer attitude
great circle. Figure 2 displays an example of the retro-deformation process given the following
data:

Regional tangent layer attitude: N 30 E 64 E
Top/Bottomset attitude: N 10 W 72 W
Foreset attitude: N 13 W 76 W

In this example the step 1 rotation is -58 degrees about the step 1 rotation axis (see Figure 2)
that rotates the pole to the top/bottomset attitude (TP) to the pole to the regional tangent layer
(RP). The foreset pole is rotated in the same manner moving the FP to FP’ in Figure 2. Both of
the step 1 rotations occur about the step 1 rotation axis, that is itself the pole to the plane
containing TP and RP. The plane containing TP and RP is indicated in Figure 2 by the great
circle passing through these two points. Because of the geometrical model used by CROSSBED
rotations viewed down-plunge of the rotation axis are positive if counterclockwise, and negative
if clockwise. Therefore, visualization of TP being rotated through less than 90 degrees to the RP
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Figure 3: Example of crossbed rotation path with
overturned bedding.

position in Figure 2 must be
clockwise (i.e. -58 degrees).
Rotation of FP by -58 degrees to
FP’ about the step 1 axis is
indicated by the small circle path in
Figure 2. Unless the top/bottomset
bedding is overturned, the absolute
value of the rotation is always less
than 90 degrees.  In the case of
overturned top/bottomset bedding
the absolute value of the step 1
rotation is greater than 90 degrees-
in the Figure 3 example -168
degrees. The step 2 rotation is
always less than 90 degrees since it
simply removes the dip from the
regional tangent layer attitude.

File Formats

The initial screen window of the
CROSSBED application displays 2
child windows- the “Edit” window
that should contain the input file,
and the “Results” window that
contains the output results of the
retro-deformation. When either of
the  child windows has the input
focus choosing the “File” > “Save”
option will write the window
contents to a disk file. Below is a discussion of the “Edit” and “Results” window file formats.

Input File Format

The input file format consists of a planar foreset attitude followed by a top/bottomset attitude
and an optional ID label. The format of the planar attitudes may vary among several common
types. This can be set in the “Settings” menu (see discussion below). In the Figure 4 example
the “Edit” window contains several foreset followed by top/bottomset attitude pairs in quadrant
planar format. Note that the foreset attitude is always first on each line. A data identifier string
may follow the top/bottomset attitude. If the top/bottomset attitude is overturned, an “O” should 
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Figure 4: Example input and output windows in CROSSBED.

follow the attitude (see Figure 4 edit window example).  

Output File Format

The output of the
application is
contained in the
"results" child
window (Figure 4).
The contents of this
window may be
saved as a text file
that may be used as
input for the
stereographic
analysis  program
NETPROG. The
rotated position of
the foreset poles are
included in the
results file. In
addition, the rotation
path of the foreset
pole may be
optionally included
as a series of user-defined annotations, as in the Figure 4 example. Figure 5 displays the
CROSSBED output results in the NETPROG application main window. Note that the small
circle paths of the 2-step rotation retro-deformation are plotted along with the retro-deformed
foreset pole. The small circle step-1 paths greater than 90 degrees are produced by the
overturned top/bottomset beds (see Figure 4). 

The NETPROG application (see later section on working with external applications)  contains all
of the options necessary to generate publication quality diagrams, including contoured equal-area
and rose diagrams. The NETPROG application can also evaluate the statistical significance of
orientation trends in the data set. If the user wishes to plot the retro-deformed foreset beds as a
paleocurrent rose-type diagram, the output format should be set to “Azimuth/Quadrant Foreset
True Dip” type (see “settings” menu discussion below), and the rotation path should be de-
selected. The same retro-deformed data plotted in Figure 5 is plotted in Figure 6 with these
settings so that the paleocurrent direction is indicated in a Rose-type diagram. The statistical
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Figure 5: Retro-deformed Heflin area foreset  poles  with
2-step rotation  paths. 

least-squares vector fit is also plotted in Figure 6 indicating a mean paleoslope true dip attitude
of 5, S45E.

The CROSSBED Menu System

Configuring and data processing is accomplished through the main menu system of the
CROSSBED application. Below is a description of each of the main and submenu items, and
how they are used to process data.

The File Menu

The file menu contains dialogs for
opening and saving data files. In
many cases the input data files may
be created in other applications
such as spreadsheets and database
management systems. A separate
discussion with examples of how
this may be accomplished is
discussed in a later section. 

The “Open” Menu Item in the
File Menu

Selecting the menu choice “File” >
“Open” allows the user to open an
existing data file that is formatted
specifically for CROSSBED.
Activating this menu option will
display a standard “File Open”
operating system dialog that will
display all files with a “.TXT”
extension in the default folder
(Figure 7). Selecting a text file and
then clicking on the “Open” button
will load the file into the “Edit”
child window. The edit window is a
fully functional text editor,
therefore, it is possible to type in all
of the data manually into the editor and then save the data to a disk file. It is also possible to
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Figure 6: Rose-type diagram of the retro-deformed Heflin
paleocurrent data.

open an existing file, and then add
new data to the editor window, and
then save all of the data to a file. If
the file name already exists, the user
will be prompted to verify that the
file should be over-written.

The “Save” Menu Item in the File
Menu

The “File” > “Save” option in the
main menu is used to save the
contents of either the “Edit” or
“Results” window to a disk file.
When the “Save” option is selected
the CROSSBED program detects
which of the two child windows has
the focus, and then saves the
contents of the window to a disk
file. If the file name indicated
already exists the program will ask
if the user wants to overwrite the
existing file. The file used in the
save operation is added to the child
window caption (“Edit” or
“Results”) inside the square
brackets. If the contents of the
“Results” window have not been
saved the brackets will be empty. If
a file name has already been
indicated by the user in a save operation, a subsequent save will re-use the file name. If the user
indicates “yes” to overwriting the existing file, the same file will then contain the current
contents of the active child window. 

The “Save As” Menu Item in the File Menu

The “Save As” dialog activated from the “File” menu activates the same operating system dialog
that the “Save” option activates. See the above discussion of the “Save” option.

The “Exit” Menu Item in the File Menu
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Figure 7: Dialog opened with the “File” > “Open” option.

Figure 8: The “File Save” option from the “File” menu.

The “Exit” option in the main “File”
menu will exit the CROSSBED
application, abandoning any data
contained in the child windows.
Make sure that you have saved any
newly added data before selecting
this option. You can also exit the
program by selecting the “X” icon
in the upper right corner of the main
application window.

The Edit Menu

The “Edit” main menu is mainly
used to copy and paste text from one window to another, or from one application to another. The
paste operation is especially important when “pasting” data from external applications.

The “Cut” Menu Item in the Edit Menu

Selecting the CUT menu item under
the EDIT menu allows for the
deletion of selected text in the
currently active editor window.
Although the text will disappear
from the edit window, it will be
copied to the windows clipboard
where it may be "pasted" into
another Windows application. The
<DEL> will cause the same effect
when text is highlighted.

The “Copy” Menu Item in the
Edit Menu

Selection of the COPY item in the edit menu will cause any selected text to be copied to the
Windows system clipboard. The contents of the clipboard can be pasted into other application
usually be selecting the applications PASTE item from the applications EDIT menu. Typically
this operation is used  to copy-and-paste the results of the CROSSBED retro-deformation into
another spreadsheet or database application.  Highlighting text for copying is most easily
accomplished by dragging the pointing device with the left button held down. Holding down the
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shift key while move the pointer with the cursor keys or the mouse will cause the same effect.

The “Paste” Menu Item in the Edit Menu

Selection of the “Paste” item in the “Edit” menu will place the contents of the Windows
clipboard text into the currently active child window (edit or results). The active window that has
the focus will have a title bar background with the default windows background color. The
inactive window's title bar will have a gray background color. Usually, the paste item will be
used to paste data from another application into the edit window. For example, a data query may
be used in Access to produce a CROSSBED compatible input file, and then copied to the
clipboard. The “Paste” menu would then be used in CROSSBED in the Edit window to paste the
results into the window.  The shift+insert key combination is a shortcut for the paste-from-
clipboard command (this is true in any windows program). 

The “Clear” Menu Item in the Edit Menu

Selection of the “Clear” menu item in the “Edit” menu will delete all text in the currently active
window. This command is normally selected to either clear the results window in preparation for
processing another data set, or to begin a new data set in the edit window.

The “Run” Menu

The “Run” menu is chosen when data has been entered or loaded into the “Edit” window and all
settings for data format have been set. The only item on this menu is the “Process data” item that
processes the retro-deformation and lists the results in the “Results” window.

The “Process Data” Menu Item in the Edit Menu

If you select the “Process Data” command under the “Run” menu CROSSBED will begin to scan
the contents of the current edit window and process the data while writing output results to the
“Results” window. The output in the results window is fully formatted for the NETPROG
application, therefore, you can and should save it to a disk file immediately after creating it. The
results window is a functional text editor window, so you may modify the results window to suit
your purpose. A log file named "CrossbedLog.txt" is created concurrently with the output in the
results window. It will contain a record of each processed data pair, including the rotation axes
and amounts used in the retro-deformation steps. Note that all of the above files created by
CROSSBED are ASCII text files that can be viewed and edited by virtually any text editor
including the “Notepad” editor that comes with Windows.

The Settings Menu



CROSSBED: An Application For Determining Paleocurrent
Direction from Polydeformed Cross-bedding Data

Page 9 of  18

Figure 9: The Regional Attitude dialog
window.

The items in the “Settings” menu determine the input and output data format, and the reference
regional sheet tangent layer attitude (see Figure 1).  

The “Regional Attitude” Menu Item in the Settings Menu

The “Regional Attitude” item in the Settings Menu
determines the attitude of the tangent sheet layer
attitude. This is the layer that the top/bottomset
bedding is rotated to co-planar orientation in the
1st-step rotation. The regional attitude should be
determined by statistically analyzing the folded
bedding to determine the best-fit cylindrical fold
hinge. The fold hinge will then be the true-dip
vector of the regional tangent sheet layer. Figure 9
displays the dialog window activated by choosing
the “Regional Attitude” menu item. The regional
attitude may be entered in several different planar attitude formats indicated in the list box in the
right side of the window:

Format Keyword Description
QuadPlanes Quadrant planar attitude format: N 45 E 30 E
AzPlanes Azimuth planar attitude format: 045 30 E
DipAzimuth Dip azimuth, dip angle first: 30 135

(Note: all of the above are equivalent planar
attitudes.)

When entering an attitude in the upper right edit box make sure that the attitude format matches
the format settings in the format list box. All elements of the attitude should be separated by at
least one blank. For the dip quadrant direction use only an “E” or “W”. Do not use an “N” or an
“S” even if the dip direction is due north or south. In cases where the true dip direction is due
north or south use the following rule:

If the strike is N 90 E and the true dip is 30 south: N 90 E 30 E
if the strike is N 90 E and the true dip is 30 north: N 90 E 30 W

The “Rotation Type” radio buttons in the lower right of the of the dialog window control the
type of rotation- either a complex 2-step or a simple 1-step process. The 2-step process rotates
the top/bottomset and paired foreset so that the top/bottomset attitude is co-planar to the regional
tangent sheet layer attitude. The regional tangent layer is then rotated about its strike line to
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Figure 10: Input format dialog window.

remove the dip, moving the foreset beds to their depositional attitude. In the 1-step simple
rotation the top/bottomsets with paired foresets are simply rotated to be co-planar with the
regional tangent sheet layer. 

The “Input Format” Menu Item in the Settings Menu

The “Input Format” menu item
dialog sets the format of the input
data in the edit window. The default
is quadrant planar for both the
foreset and top/bottomset columns
(columns 1 and 2 respectively),
however either column may be
entered as azimuth planar or dip
azimuth attitude format. See the
above discussion on the attitude
format options for the regional
tangent sheet layer for a description
of the various formats. In Figure 10
the layout of the dialog is displayed with the possible options. Figure 4 displays an example of
input data from the Heflin, AL, area in quadrant planar format. Note that in the 2nd top/bottomset
column that overturned beds are indicated with a following “O” after the dip quadrant direction
indicator.

The “Output Format” Menu Item in the Settings Menu

The “Output Format” menu item is used to set the output format for the results window. The
possible output formats for the retro-deformed foreset beds are described below:

Format Description
Quadrant Planar Attitude of Foreset Quadrant planar attitude of retro-deformed

foreset (ex. N 30 E 17 E)
Azimuth Planar Attitude of Foreset Azimuth planar attitude of retro-defromed

foreset (ex. 030 17 E)
Dip azimuth Planar Attitude of Foreset Dip azimuth planar attitude of retro-

deformed foreset (ex. 17 150)
Azimuth Linear Pole to Foreset Azimuth linear attitude of retro-deformed

foreset pole.
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Figure 11: Output format dialog window.

Quadrant Linear Pole to Foreset Quadrant linear attitude of retro-deformed
foreset pole.

Quadrant Linear Foreset True Dip Quadrant linear attitude of retro-deformed
foreset true dip.

Azimuth Linear Foreset True Dip Azimuth linear attitude of retro-deformed
foreset true dip.

The first 3 options generate output in the
results window in quadrant planar, azimuth
planar, or dip azimuth attitudes. When this
data is processed by NETPROG the planar
attitudes are usually plotted as poles. If the
“plot rotation paths” option is “on”, the
retro-deformation paths of the foreset poles
are plotted as a series of small circle paths.
Because the retro-deformed position of the
foreset poles are plotted as symbols, the
resulting NETPROG plot can be
interpreted in terms of the retro-
deformation path. Figure 5 is an example
of this type of plot. Note that in this
diagram the small circle paths greater than
90 degrees are overturned beds. 

The Quadrant Linear Pole and Azimuth
Linear Pole options will write the results as
linear “Pole” attitudes. The main use of
these options would be to simply convert the retro-deformed planar foresets to a linear pole
attitude.

The last 2 options produce linear attitudes of the true dip vector of the retro-deformed foreset
beds. The main use of these options is to convert the retro-deformed foreset to a paleocurrent
direction. Choosing one of these options allows the results window to be used in NETPROG as a
Rose-type diagram. Figure 6 is an example using the Heflin area data. 

The “Plot rotation paths” check box in the lower left portion of the dialog window controls
whether or not the retro-deformation path is included in the results window as annotations. If the
user wishes to evaluate the retro-deformation paths of the foresets, this option should be
checked. If the results window contains foreset true dip paleocurrent direction data (i.e. the last 2
output formats) this option should be unchecked. 
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The Window Menu 
The “Window” menu contains options that control the display of the edit and results child
windows of the main CROSSBED application window.

The “Cascade” Menu Item in the Window Menu

Selecting the “Cascade” windows option in the “Window” menu will cause both child windows
to be displayed so that both child window captions are visible, and the window with the focus is
in the foreground. 

The “Tile Horizontally” Menu Item in the Window Menu

The “Tile Horizontally” option will cause both child windows to be sized to take up exactly half
of the area of the CROSSBED application window. The dividing line between the two child
windows runs horizontally midway through the CROSSBED application window.

The “Tile Vertically” Menu Item in the Window Menu

The “Tile Vertically” menu option in the “Windows” menu operates in the same way as the
above “Tile Horizontally” option except that the dividing line runs vertically midway through
the CROSSBED application window area.

The “Minimize All” Menu item in the Windows Menu

The “Minimize All” menu option in the “Windows” menu will cause both of the edit and results
child windows to become minimized as icons and re-located to the lower left portion of the
CROSSBED application window.

The Help Menu

The “Help” menu contains links to the CROSSBED help system that consists of a PDF file with
bookmarks to specific help topics related to CROSSBED. The menu also contains the “About”
and “How to Use Help” dialog windows.

The “How to Use Help” Menu Item in the Help Menu

Selecting the menu item will display a dialog window containing directions on how to
effectively use the Adobe PDF reader to open and read the CROSSBED help document.

The “Help File” Menu Item in the Help Menu
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Selecting the “Help File” menu item in the “Help” menu will activate the Adobe PDF reader to
load “Crossbed_Help.pdf” file located at the URL or disk file path indicated in the
“Crossbed.ini” file. 

The “About” Menu Item in the Help Menu

The “About” menu item displays a dialog window containing version information for the
CROSSBED application, and an e-mail address for the author. Use this to contact the author of
the program.

CROSSBED Input Data File Format

Input data for CROSSBED should be loaded or typed into the “Edit” window. The data should
consist of 2 planar attitudes and an optional sample I.D. label for each line. The foreset attitude
should be first, followed by the top/bottomset. If the top/bottomset bedding is overturned an “O”
should follow that attitude. Any text to the right of a semi-colon (;) is treated as a comment.
Blank lines are ignored by CROSSBED.

; Bulls Gap crossbed data 
N 67 E 42 E     N 75 E 34 E       NT617 
N 15 E 45 E     N 40 E 46 E       NT617 
N 30 E 45 E     N 75 E 40 E       NT619 
N 45 E 43 E     N 55 E 28 E       NT620 
N  2 E 16 E     N 30 E 23 E       NT623 
N 72 W 28 W     N 72 E 29 E       NT625 
N 82 E 39 E     N 67 E 34 E       NT625 
N 39 E 35 E     N 67 E 24 E       NT628 
N 47 E 22 E     N 15 E 20 E       NT630 

Although the above example data are aligned in columns this is not necessary as long as
elements of both attitudes are separated by at least one blank. The above data are in quadrant
planar format, however, Azimuth planar and dip azimuth formats are also supported. 

CROSSBED Output Data File Format

The output results of the CROSSBED program is displayed in the “Results” child window. If
this window has the focus, and the “File” > “Save” or “File” > “Save As” menu item is selected,
the results are saved to a text file that can be used as input for the stereonet analysis and plotting
application NETPROG. Using the above input data example (Bulls Gap) with a regional tangent
sheet attitude of N30E, 35 SE would produce the following results:
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DataType=QuadPlanes
N 32.9 E 9.4 E NT617
N 64.3 W 17.8 E NT617
N 31.7 W 30.3 E NT619
N 26.1 E 16.0 E NT620
N 70.5 E 11.5 W NT623
N 4.7 W 17.0 W NT625
N 52.2 W 10.2 W NT625
N 1.7 W 17.4 E NT628
N 68.1 W 11.5 W NT630
User=Arc  S 34.9 E 32.4 N 23.0 W 48.0    25.05     25 Black 0.005
User=Arc  N 30.0 E -0.0 N 59.3 W 45.6    35.00     35 Black 0.005
User=Arc  N 59.4 E 19.0 N 75.0 W 45.0    12.75     13 Black 0.005
User=Arc  N 30.0 E -0.0 S 90.0 W 52.5    35.00     35 Black 0.005
User=Arc  S 49.8 E 34.6 N 60.0 W 45.0    27.35     27 Black 0.005
User=Arc  N 30.0 E -0.0 S 87.2 W 34.7    35.00     35 Black 0.005
User=Arc  S 15.8 E 26.7 N 45.0 W 47.0    14.69     15 Black 0.005
User=Arc  N 30.0 E -0.0 N 61.4 W 39.0    35.00     35 Black 0.005
User=Arc  N 30.0 E -0.0 N 88.0 W 74.0   -12.00     12 Black 0.005
User=Arc  N 30.0 E -0.0 N 76.5 W 62.8    35.00     35 Black 0.005
User=Arc  S 22.1 E 28.9 N 18.0 E 62.0    22.62     23 Black 0.005
User=Arc  N 30.0 E -0.0 N 34.7 W 67.1    35.00     35 Black 0.005
User=Arc  S 38.3 E 33.0 N 8.0 W 51.0    20.73     21 Black 0.005
User=Arc  N 30.0 E -0.0 N 42.2 W 55.1    35.00     35 Black 0.005
User=Arc  S 7.9 E 23.3 N 51.0 W 55.0    20.83     21 Black 0.005
User=Arc  N 30.0 E -0.0 N 71.7 W 39.5    35.00     35 Black 0.005
User=Arc  N 45.1 E 10.4 N 43.0 W 68.0   -16.41     16 Black 0.005
User=Arc  N 30.0 E -0.0 N 41.4 W 51.9    35.00     35 Black 0.005

The above output file contains the retro-deformed attitude of the foreset beds listed in the above
input file in lines 2-10. The first line contains a data type command that would be used by the
stereographic analysis application NETPROG if the file were used as an input file for that
application. The lines 11-28 contain a series of user-defined annotation commands for
NETPROG that display the foreset pole small-circle arc paths of the retro-deformation process.
These would be plotted on the diagram as in the Figure 5 example. Note that there are 2 small
circle arc paths for each data for the complex 2-step retro-deformation process. The format of the
small circle arc command:

user = Arc {attitude of rotation axis} {attitude of start of arc} {rotation angle in degrees}
{rotation steps} {color} {arc line width in inches}

The sense of the rotation is counter-clockwise for positive angles as viewed in the down-plunge
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direction of the rotation axis. The format of the small circle are command is explained in detail
in the NETPROG application help file.

CROSSBED Log File

Each time the “Run” > “Process Data” menu item is selected to retro-deform the data in the
“Edit” window the results of the retro-deformation process used to bring the foreset attitudes to
their original depositional attitude is written to a text “log” file named “CrossbedLog.txt”. This
file is useful for documenting the details of the retro-deformation process used by CROSSBED.
The below log file was produced by CROSSBED during the 2-step retro-deformation of the
above Bulls Gap data set:

------------ Complex 2-step rotation ----------------
Sample I.D.=NT617
1st rotation angle alpha=   25.05
Rotation axis=145.1 32.4
Foreset pole start attitude=337.0 48.0
Foreset pole 1st rotation attitude=300.7 45.6
2nd rotation angle gamma=     35.00
2nd rotation axis attitude=30.0 0.0
Foreset pole 2nd rotation attitude=302.9 80.6
Foreset paleocurrent (down-dip) attitude=9.38 122.85
------------ Complex 2-step rotation ----------------
Sample I.D.=NT617
1st rotation angle alpha=   12.75
Rotation axis=59.4 19.0
Foreset pole start attitude=285.0 45.0
Foreset pole 1st rotation attitude=270.0 52.5
2nd rotation angle gamma=     35.00
2nd rotation axis attitude=30.0 0.0
Foreset pole 2nd rotation attitude=205.7 72.2
Foreset paleocurrent (down-dip) attitude=17.79 25.66
------------ Complex 2-step rotation ----------------
Sample I.D.=NT619
1st rotation angle alpha=   27.35
Rotation axis=130.2 34.6
Foreset pole start attitude=300.0 45.0
Foreset pole 1st rotation attitude=267.2 34.7
2nd rotation angle gamma=     35.00
2nd rotation axis attitude=30.0 0.0
Foreset pole 2nd rotation attitude=238.3 59.7
Foreset paleocurrent (down-dip) attitude=30.34 58.28
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------------ Complex 2-step rotation ----------------
Sample I.D.=NT620
1st rotation angle alpha=   14.69
Rotation axis=164.2 26.7
Foreset pole start attitude=315.0 47.0
Foreset pole 1st rotation attitude=298.6 39.0
2nd rotation angle gamma=     35.00
2nd rotation axis attitude=30.0 0.0
Foreset pole 2nd rotation attitude=296.1 74.0
Foreset paleocurrent (down-dip) attitude=16.04 116.07
------------ Complex 2-step rotation ----------------
Sample I.D.=NT623
1st rotation angle alpha=  -12.00
Rotation axis=30.0 0.0
Foreset pole start attitude=272.0 74.0
Foreset pole 1st rotation attitude=283.5 62.8
2nd rotation angle gamma=     35.00
2nd rotation axis attitude=30.0 0.0
Foreset pole 2nd rotation attitude=160.5 78.5
Foreset paleocurrent (down-dip) attitude=11.50 340.49
------------ Complex 2-step rotation ----------------
Sample I.D.=NT625
1st rotation angle alpha=   22.62
Rotation axis=157.9 28.9
Foreset pole start attitude=18.0 62.0
Foreset pole 1st rotation attitude=325.3 67.1
2nd rotation angle gamma=     35.00
2nd rotation axis attitude=30.0 0.0
Foreset pole 2nd rotation attitude=85.3 73.0
Foreset paleocurrent (down-dip) attitude=16.99 265.27
------------ Complex 2-step rotation ----------------
Sample I.D.=NT625
1st rotation angle alpha=   20.73
Rotation axis=141.7 33.0
Foreset pole start attitude=352.0 51.0
Foreset pole 1st rotation attitude=317.8 55.1
2nd rotation angle gamma=     35.00
2nd rotation axis attitude=30.0 0.0
Foreset pole 2nd rotation attitude=37.8 79.8
Foreset paleocurrent (down-dip) attitude=10.20 217.76
------------ Complex 2-step rotation ----------------
Sample I.D.=NT628
1st rotation angle alpha=   20.83
Rotation axis=172.1 23.3
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Foreset pole start attitude=309.0 55.0
Foreset pole 1st rotation attitude=288.3 39.5
2nd rotation angle gamma=     35.00
2nd rotation axis attitude=30.0 0.0
Foreset pole 2nd rotation attitude=268.3 72.6
Foreset paleocurrent (down-dip) attitude=17.38 88.29
------------ Complex 2-step rotation ----------------
Sample I.D.=NT630
1st rotation angle alpha=  -16.41
Rotation axis=45.1 10.4
Foreset pole start attitude=317.0 68.0
Foreset pole 1st rotation attitude=318.6 51.9
2nd rotation angle gamma=     35.00
2nd rotation axis attitude=30.0 0.0
Foreset pole 2nd rotation attitude=21.9 78.5
Foreset paleocurrent (down-dip) attitude=11.50 201.91
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